Skip to main content

Sequelize Versioning Policy

Sequelize follows semantic versioning (semver) principles. Learn more about semver here.

This page regroups information related to which engines versions are supported by Sequelize

Releases

SequelizeNode.jsTypescriptRelease DateEOL
7 (alpha)^14.17.0 || >= 16.0.0>= 4.5
6 (current)>= 10>= 4.12020-06-24
5 (eol)>=6>= 3.12019-03-132022-01-01

* ❓ means the date has not been determined yet.

PostgreSQL Support Table

PostgreSQL requires the use of the pg (or pg-native) npm package.
Read more about this here.

note

According to pg's documentation, only pg >= 8.2 is compatible with Node 14.
If you're trying to use Sequelize 6 in Node 14 or newer, use that version of pg.

SequelizePostgreSQLpgpg-native
7 (alpha)>= 10>= 8.2>=3.0.0 ⚠️1
6 (current)>= 9.5>= 7.8 (node < 14)
>= 8.2 (node >= 14)
>=3.0.0

MariaDB Support Table

MariaDB requires the use of the mariadb npm package.
Read more about this here.

SequelizeMariaDBmariadb (npm)
7 (alpha)>=10.3>= 3.0.0 ⚠️2
6 (current)>=10.3^2.3.3

MySQL Support Table

MySQL requires the use of the mysql2 npm package.
Read more about this here.

SequelizeMySQLmysql2
7 (alpha)^5.7, ^8.0>= 2.3.3
6 (current)^5.7, ^8.0>= 2.3.3

Microsoft SQL Server (mssql) Support Table

MSSQL requires the use of the tedious npm package.
Read more about this here.

SequelizeSQL Servertedious
7 (alpha)2017-2022^14.4.0
6 (current)2014-2019^8.3.0

SQLite Support Table

Sequelize uses the sqlite3 npm library.
Read more about this here.

note

[email protected]^4 has security vulnerabilities which are fixed by the @vscode/sqlite3 fork. We recommend using that if you can not update to [email protected]^5.0.3.

Sequelizesqlite3
7 (alpha)[email protected]^5.0.3
6 (current)@vscode/[email protected]^4.0.12, or [email protected]^5.0.3

Snowflake Support Table

Snowflake requires the use of the snowflake-sdk npm package.
Read more about this here.

note

While this dialect is included in Sequelize, support for Snowflake is limited as it is not handled by the core team.

SequelizeSnowflakesnowflake-sdk
7 (alpha)all^1.6.0
6 (current)all^1.6.0

Db2 Support Table

Db2 requires the use of the ibm_db npm package.
Read more about this here.

note

While this dialect is included in Sequelize, support for Db2 is limited as it is not handled by the core team.

SequelizeDb2ibm_db
7 (alpha)>= 11.5^2.8.0
6 (current)>= 11.5^2.8.0

Db2 for IBM i Support Table

Db2 for IBM i requires the use of the odbc npm package.
Read more about this here.

note

While this dialect is included in Sequelize, support for Db2 for IBM i is limited as it is not handled by the core team.

SequelizeDb2 for IBM iodbc
7 (alpha)unknown^2.4.0
6 (current)not availablenot available

Oracle Database Support Table

Oracle Database requires the use of the node-oracledb npm package.
Read more about this here.

SequelizeOracle Databasenode-oracledb
7 (alpha)upcomingupcoming
6 (current)>= 18.4^5.4.0

  1. pg-native hasn't had a release since 2018. Sequelize will still test against it, but its reliability is degraded in Node >=17.
  2. Support for mariadb 3 has not been completed yet https://github.com/sequelize/sequelize/pull/14187